How to configure PIM-DM (Dense-Mode) on ECS4620 Series? Follow
Scenario:
Configuration on SW1:
Setup VLAN
SW1#configure
SW1(config)#interface ethernet 1/1
SW1(config-if)#switchport allowed vlan add 10 untagged
SW1(config-if)#switchport native vlan 10
SW1(config-if)#switchport allowed vlan remove 1
SW1(config-if)#interface ethernet 1/12
SW1(config-if)#switchport allowed vlan add 20 untagged
SW1(config-if)#switchport native vlan 20
SW1(config-if)#switchport allowed vlan remove 1
SW1(config-if)#interface vlan 10
SW1(config-if)#ip address 192.168.10.254/24
SW1(config-if)#interface vlan 20
SW1(config-if)#ip address 192.168.20.1/24
SW1(config-if)#end
Enable OSPF
SW1#configure
SW1(config)#router ospf 1
SW1(config-router)#network 192.168.10.0 255.255.255.0 area 0
SW1(config-router)#network 192.168.20.0 255.255.255.0 area 0
SW1(config-router)#end
Enable Multicast Routing and PIM
SW1#configure
SW1(config)#ip multicast-routing
Note: IPv6 multicast routing will also be enabled.
SW1(config)#router pim
SW1(config-router)#end
Enable IGMP and PIM Dense-Mode on VLAN
SW1#configure
SW1(config)#interface vlan 10
SW1(config-if)#ip igmp
SW1(config-if)#ip pim dense-mode
SW1(config-if)#interface vlan 20
SW1(config-if)#ip igmp
SW1(config-if)#ip pim dense-mode
SW1(config-if)#end
Configuration on SW2:
Setup VLAN
SW2#configure
SW2(config)#interface ethernet 1/1
SW2(config-if)#switchport allowed vlan add 30 untagged
SW2(config-if)#switchport native vlan 30
SW2(config-if)#switchport allowed vlan remove 1
SW2(config-if)#interface ethernet 1/12
SW2(config-if)#switchport allowed vlan add 20 untagged
SW2(config-if)#switchport native vlan 20
SW2(config-if)#switchport allowed vlan remove 1
SW2(config-if)#interface vlan 30
SW2(config-if)#ip address 192.168.30.254/24
SW2(config-if)#interface vlan 20
SW2(config-if)#ip address 192.168.20.2/24
SW2(config-if)#end
Enable OSPF
SW2#configure
SW2(config)#router ospf 1
SW2(config-router)#network 192.168.30.0 255.255.255.0 area 0
SW2(config-router)#network 192.168.20.0 255.255.255.0 area 0
SW2(config-router)#end
Enable Multicast Routing and PIM
SW2#configure
SW2(config)#ip multicast-routing
Note: IPv6 multicast routing will also be enabled.
SW2(config)#router pim
SW2(config-router)#end
Enable IGMP and PIM Dense-Mode on VLAN
SW2#configure
SW2(config)#interface vlan 30
SW2(config-if)#ip igmp
SW2(config-if)#ip pim dense-mode
SW2(config-if)#interface vlan 20
SW2(config-if)#ip igmp
SW2(config-if)#ip pim dense-mode
SW2(config-if)#end
Test Result:
SW1,
Display PIM status and PIM neighbor for the specified interface
SW1#show ip pim interface
PIM is enabled.
VLAN 1 is down.
PIM Mode : Unspecified
VLAN 10 is up.
PIM Mode : Dense Mode
IP Address : 192.168.10.254
Hello Interval : 30 sec
Hello HoldTime : 105 sec
Triggered Hello Delay : 5 sec
Join/Prune Holdtime : 210 sec
Lan Prune Delay : Disabled
Propagation Delay : 500 ms
Override Interval : 2500 ms
Graft Retry Interval : 3 sec
Max Graft Retries : 3
State Refresh Ori Int : 60 sec
VLAN 20 is up.
PIM Mode : Dense Mode
IP Address : 192.168.20.1
Hello Interval : 30 sec
Hello HoldTime : 105 sec
Triggered Hello Delay : 5 sec
Join/Prune Holdtime : 210 sec
Lan Prune Delay : Disabled
Propagation Delay : 500 ms
Override Interval : 2500 ms
Graft Retry Interval : 3 sec
Max Graft Retries : 3
State Refresh Ori Int : 60 sec
SW1#show ip pim neighbor
Neighbor Address VLAN Interface Uptime (sec.) Expiration Time (sec) DR
---------------- -------------- ------------- --------------------- ---
192.168.20.2/32 20 00:49:11 00:01:35 Yes
Display the multicast information for the specified interface
SW1#show ip igmp interface
VLAN 1 : down
IGMP : Disabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 0.0.0.0
Joined Groups :
Static Groups :
VLAN 10 : up
IGMP : Enabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 192.168.10.254
Joined Groups :
239.255.255.250
Static Groups :
VLAN 20 : up
IGMP : Enabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 192.168.20.1
Joined Groups :
Static Groups :
SW1#show ip igmp groups
GroupAddress Interface Vlan Last Reporter Uptime Expire V1 Timer
--------------- --------------- --------------- -------- -------- ---------
239.255.255.250 10 192.168.10.1 0:56:7 0:2:59 0:0:0
Display the information in the routing table
SW1#show ip route
Codes: C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
C 192.168.10.0/24 is directly connected, VLAN10
C 192.168.20.0/24 is directly connected, VLAN20
O 192.168.30.0/24 [110/2] via 192.168.20.2, VLAN20, 00:02:43
Display the IPv4 multicast routing table
SW1#show ip mroute
IP Multicast Forwarding is enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Channel, C - Connected, P - Pruned,
F - Register flag, R - RPT-bit set, T - SPT-bit set, J - Join SPT
Interface state: F - Forwarding, P - Pruned, L - Local
(192.168.10.1, 224.1.1.1), uptime 00:27:09, stat expires 00:02:16
Owner: PIM-DM, Flags: DC
Incoming interface: VLAN 10
Outgoing interface list:
VLAN20 (F)
(192.168.30.1, 239.255.255.250), uptime 00:02:54
Owner: PIM-DM, Flags: D
Incoming interface: VLAN 20, RPF neighbor: 192.168.20.2
Outgoing interface list:
VLAN10 (F) ,
SW2,
Display PIM status and PIM neighbor for the specified interface
SW2#show ip pim interface
PIM is enabled.
VLAN 1 is down.
PIM Mode : Unspecified
VLAN 20 is up.
PIM Mode : Dense Mode
IP Address : 192.168.20.2
Hello Interval : 30 sec
Hello HoldTime : 105 sec
Triggered Hello Delay : 5 sec
Join/Prune Holdtime : 210 sec
Lan Prune Delay : Disabled
Propagation Delay : 500 ms
Override Interval : 2500 ms
Graft Retry Interval : 3 sec
Max Graft Retries : 3
State Refresh Ori Int : 60 sec
VLAN 30 is up.
PIM Mode : Dense Mode
IP Address : 192.168.30.254
Hello Interval : 30 sec
Hello HoldTime : 105 sec
Triggered Hello Delay : 5 sec
Join/Prune Holdtime : 210 sec
Lan Prune Delay : Disabled
Propagation Delay : 500 ms
Override Interval : 2500 ms
Graft Retry Interval : 3 sec
Max Graft Retries : 3
State Refresh Ori Int : 60 sec
SW2#show ip pim neighbor
Neighbor Address VLAN Interface Uptime (sec.) Expiration Time (sec) DR
---------------- -------------- ------------- --------------------- ---
192.168.20.1/32 20 00:52:26 00:01:23
Display the multicast information for the specified interface
SW2#show ip igmp interface
VLAN 1 : down
IGMP : Disabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 0.0.0.0
Joined Groups :
Static Groups :
VLAN 20 : up
IGMP : Enabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 192.168.20.1
Joined Groups :
Static Groups :
VLAN 30 : up
IGMP : Enabled
IGMP Proxy : Disabled
IGMP Version : 2
IGMP Unsolicited Report Interval : 400 sec
Robustness Variable : 2
Query Interval : 125 sec
Query Max Response Time : 100 (resolution in 0.1 sec)
Last Member Query Interval : 10 (resolution in 0.1 sec)
Querier : 192.168.30.254
Joined Groups :
224.1.1.1
239.255.255.250
Static Groups :
SW2#show ip igmp groups
GroupAddress Interface Vlan Last Reporter Uptime Expire V1 Timer
--------------- --------------- --------------- -------- -------- ---------
224.1.1.1 30 192.168.30.1 0:5:26 0:3:35 0:0:0
239.255.255.250 30 192.168.30.1 0:5:28 0:3:28 0:0:0
Display the information in the routing table
SW2#show ip route
Codes: C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
O 192.168.10.0/24 [110/2] via 192.168.20.1, VLAN20, 00:06:38
C 192.168.20.0/24 is directly connected, VLAN20
C 192.168.30.0/24 is directly connected, VLAN30
Display the IPv4 multicast routing table
SW2#show ip mroute
IP Multicast Forwarding is enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Channel, C - Connected, P - Pruned,
F - Register flag, R - RPT-bit set, T - SPT-bit set, J - Join SPT
Interface state: F - Forwarding, P - Pruned, L - Local
(192.168.10.1, 224.1.1.1), uptime 00:06:53
Owner: PIM-DM, Flags: D
Incoming interface: VLAN 20, RPF neighbor: 192.168.20.1
Outgoing interface list:
VLAN30 (F)
(192.168.30.1, 239.255.255.250), uptime 00:07:39, stat expires 00:02:42
Owner: PIM-DM, Flags: D
Incoming interface: VLAN 30
Outgoing interface list:
VLAN20 (F) ,
Comments
0 comments
Please sign in to leave a comment.