[Enterprise Switch] How to allocate IP pool appropriately Follow
How to allocate IP pool appropriately :
DHCP address pool has a group of assignable IP addresses and network configuration parameters. The DHCP server selects IP addresses and other parameters from the address pool and assigns them to the DHCP clients.
Support models
ECS4120 series, ECS4620 series, etc.
Application
Case1 :
Different VLANs want to get different IP network segment from DHCP server.
Case 2 :
Allocate specific IP pool range on DHCP server .
Topology
Case 1 :
Case 2 :
Configurations and knowhow of case1 :
Purpose :
Vlan 100 want to get IP 10.131.48.X
Vlan 200 want to get IP 10.131.49.X
Vlan 300 want to get IP 10.131.50.X
Vlan 400 want to get IP 10.131.51.X
Vlan 500 want to get IP 10.131.52.X
Vlan 600 want to get IP 10.131.53.X
Vlan 700 want to get IP 10.131.54.X
NOTE : This device MAX DHCP server IP pool is 512
If user setup IP pool simply (just setup mask as 255.255.255.0 ) , some Vlan will not be allocate any IP .
Example :
Name Type IP Address Mask Active Pool
-------- ---- --------------- --------------- ---------------------------------
vlan100 Net 10.131.48.0 255.255.255.0
vlan200 Net 10.131.49.0 255.255.255.0
vlan300 Net 10.131.50.0 255.255.255.0
vlan400 Net 10.131.51.0 255.255.255.0
vlan500 Net 10.131.52.0 255.255.255.0 10.131.52.1 - 10.131.52.4
vlan600 Net 10.131.53.0 255.255.255.0 10.131.53.1 - 10.131.53.254
vlan700 Net 10.131.54.0 255.255.255.0 10.131.54.1 - 10.131.54.254
just 3 VLANs can got active Pool because max IP pool is 512 ,
vlan 500 = 4 , vlan 600 = 254 , vlan 700 = 254 , total is 512 , it’s full .
So we suggest it can average allocate 512 to 7 groups VLAN ,
and because he used network class A IP , it should mapping correct subnet mask ,
(user can check this link to know how to setup suitable IP& subnet mask
https://www.subnet-calculator.com/
in this case , IP is A class and we need to average allocate 512 to 7 groups VLAN , so we should use subnet mask as 255.255.255.192 , every VLAN will be allocate 62 IPs , this one is the best setup for this case )
we can adjust best setup for this case , key configuration as below :
vlan database
VLAN 1 name DefaultVlan media ethernet
vlan 100,200,300,400,500,600,700 media ethernet
!
interface vlan 100
ip address 10.131.48.1 255.255.255.0
!
interface vlan 200
ip address 10.131.49.1 255.255.255.0
!
interface vlan 300
ip address 10.131.50.1 255.255.255.0
!
interface vlan 400
ip address 10.131.51.1 255.255.255.0
!
interface vlan 500
ip address 10.131.52.1 255.255.255.0
!
interface vlan 600
ip address 10.131.53.1 255.255.255.0
!
!
interface vlan 700
ip address 10.131.54.1 255.255.255.0
!
ip dhcp pool vlan100
network 10.131.48.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan200
network 10.131.49.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan300
network 10.131.50.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan400
network 10.131.51.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan500
network 10.131.52.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan600
network 10.131.53.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
ip dhcp pool vlan700
network 10.131.54.0 255.255.255.192
netbios-node-type hybrid
lease 1 0 0
!
service dhcp
!
interface vlan 100
!
interface vlan 200
!
interface vlan 300
!
interface vlan 400
!
interface vlan 500
!
interface vlan 600
!
end
!
and you can check result as attachment "dhcp pool display for 4120".
all client VLANs can get different range IP from DHCP server .
Console#sh ip dhcp
Name Type IP Address Mask Active Pool
-------- ---- --------------- --------------- ---------------------------------
vlan100 Net 10.131.48.0 255.255.255.192 10.131.48.1 - 10.131.48.62
vlan200 Net 10.131.49.0 255.255.255.192 10.131.49.1 - 10.131.49.62
vlan300 Net 10.131.50.0 255.255.255.192 10.131.50.1 - 10.131.50.62
vlan400 Net 10.131.51.0 255.255.255.192 10.131.51.1 - 10.131.51.62
vlan500 Net 10.131.52.0 255.255.255.192 10.131.52.1 - 10.131.52.62
vlan600 Net 10.131.53.0 255.255.255.192 10.131.53.1 - 10.131.53.62
vlan700 Net 10.131.54.0 255.255.255.192 10.131.54.1 - 10.131.54.62
Total entry : 7
Configurations and knowhow of Case 2 :
Purpose :
DHCP clients want to get IP pool range from 192.168.10.1 ~ 192.168.10.99
We assume you want setup VLAN2 for DHCP IP pool ,
Setup IP range from 192.168.10.1~192.168.10.254 first ,
Then setup excluded-address : 192.168.10.100 192.168.10.254 ,
here is example (key configurations as below ):
vlan database
VLAN 1 name DefaultVlan media ethernet
vlan 2 media ethernet
!
interface vlan 2
ip address 192.168.10.168 255.255.255.0
!
ip dhcp pool vlan2
network 192.168.10.0 255.255.255.0
netbios-node-type hybrid
lease 1 0
!
ip dhcp excluded-address 192.168.10.100 192.168.10.254
!
service dhcp
!
and you can check result (command : sh ip dh) :
Name Type IP Address Mask Active Pool
-------- ---- --------------- --------------- ---------------------------------
vlan2 Net 192.168.10.0 255.255.255.0 192.168.10.1 - 192.168.10.99
Total entry : 1
Comments
0 comments
Please sign in to leave a comment.