How to configure the BGP on ECS4620 series? Follow
The BGP (Border Gateway Protocol) is to exchange network reachability information with other BGP systems. This network reachability information includes the list of Autonomous Systems (ASes).
IBGP(Internal BGP) means the connection between internal peer that is in the same Autonomous System as the local system. EBGP(External BGP) means the connection between external peer that is in a different Autonomous System than the local system.
Scenario:
Procedure:
Switch_01 Configuration:
Step 1: BGP global config. Apply VLAN on port and configure VLAN's IP address.
sw1#
sw1#configure
sw1(config)#router bgp 65000
sw1(config-router)#network 192.168.1.0 255.255.255.0
sw1(config-router)#neighbor 2.2.2.2 remote-as 65001
sw1(config-router)#exit
sw1(config)#vlan database
sw1(config-vlan)#vlan 2
sw1(config-vlan)#exit
sw1(config)#interface vlan 1
sw1(config-if)#ip address 192.168.1.254/24
sw1(config-if)#exit
sw1(config)#interface vlan 2
sw1(config-if)#ip address 2.2.2.1/24
sw1(config-if)#
sw1(config-if)#exit
sw1(config)#interface ethernet 1/11
sw1(config-if)#switchport allowed vlan add 2
sw1(config-if)#switchport native vlan 2
sw1(config-if)#
Switch_02 Configuration:
Step 1: BGP global config. Apply VLAN on port and configure VLAN's IP address.
sw2#
sw2#configre
sw2(config)#router bgp 65001
sw2(config-router)#network 2.2.2.0 255.255.255.0
sw2(config-router)#network 3.3.3.0 255.255.255.0
sw2(config-router)#neighbor 2.2.2.1 remote-as 65000
sw2(config-router)#neighbor 3.3.3.2 remote-as 65002
sw2(config-router)#exit
sw2(config)#vlan database
sw2(config-vlan)#vlan 2,3
sw2(config-vlan)#exit
sw2(config)#interface vlan 2
sw2(config-if)#ip address 2.2.2.2/24
sw2(config)#interface vlan 3
sw2(config-if)#ip address 3.3.3.1/24
sw2(config-if)#
sw2(config-if)#exit
sw2(config)#interface ethernet 1/11
sw2(config-if)#switchport allowed vlan add 2
sw2(config-if)#switchport native vlan 2
sw2(config-if)#
sw2(config)#interface ethernet 1/23
sw2(config-if)#switchport allowed vlan add 3
sw2(config-if)#switchport native vlan 3
sw2(config-if)#
Switch_03 Configuration:
Step 1: BGP global config. Apply VLAN on port and configure VLAN's IP address.
sw3#
sw3#configre
sw3(config)#router bgp 65002
sw3(config-router)#network 192.168.2.0 255.255.255.0
sw3(config-router)#neighbor 3.3.3.1 remote-as 65001
sw3(config-router)#exit
sw3(config)#vlan database
sw3(config-vlan)#vlan 3,4
sw3(config-vlan)#exit
sw3(config)#interface vlan 3
sw3(config-if)#ip address 3.3.3.2/24
sw3(config-if)#exit
sw3(config)#interface vlan 4
sw3(config-if)#ip address 192.168.2.254/24
sw3(config-if)#
sw3(config-if)#exit
sw3(config)#interface ethernet 1/1
sw3(config-if)#switchport allowed vlan add 4
sw3(config-if)#switchport native vlan 4
sw3(config)#interface ethernet 1/23
sw3(config-if)#switchport allowed vlan add 3
sw3(config-if)#switchport native vlan 3
sw3(config-if)#
bgp status:
SW1:
display the AS number and neighbor
display the routing table
SW2:
display the AS number and neighbor
display the routing table
SW3:
display the AS number and neighbor
display the routing table
Comments
0 comments
Please sign in to leave a comment.