Failed to upgrade BMC version by using CLI commands Follow
Model:
AS5916-54XKS, AS5916-54XL
One of the following symptoms:
1.BMC upgraded failed by using the CLI commands.
=== Accton Firmware Update version 1.3 ===
=== Update BMC 192.168.1.18 ===
=== FW <<as5916-54xl_bmc_v00.52.00h_firmimg>> ===
=== without preserve config ===
=== Get SessionID ===
=== Update BMC FW failed !! =========
2. BMC upgraded failed with error message: "Unable to establish LAN session" by using the CLI commands.
=== Accton Firmware Update version 1.3 ===
=== Update BMC 10.10.10.3 ===
=== FW <<tftp://10.10.10.2//as5916-54xks_bmc_v00_51_00_firmimg_ast2400.bin>> ===
=== without preserve config ===
Error: Unable to establish LAN session
=== Update BMC FW failed !! =========
Diagnosis:
Step 1: Check whether ADMIN account exists or NOT. Because it requires default ADMIN/ADMIN account for BMC upgrade.
Use "ipmitool user list 1" to check BMC user database.
ONIE:/ # ipmitool user list 1
ID Name Callin Link Auth IPMI Msg Channel Priv Limit
2 ADMIN true true true ADMINISTRATOR →ADMIN account exists.
ONIE:/ # ipmitool user list 1
ID Name Callin Link Auth IPMI Msg Channel Priv Limit
2 true true true ADMINISTRATOR →ADMIN account does not exist. Issue happened
Resolution:
Use the web interface to upgrade the BMC. How to update the BMC via the web interface?
If you want to upgrade via CLI. Since the admin account disappeared, please submit the ticket to Edgecore Support for further analysis.
Step 2: Check the communication between CPU and BMC via ping tool.
- Plug RJ45 cable to the management port.
- Assign IP addresses to CPU and BMC and make sure IP addresses belong to the same IP subnet.
- Ping from ONIE to BMC.
Caution: use ping tool on ONIE, not on the PC.
ONIE:/ # ip address | grep eth0
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq qlen 1000
inet 10.10.10.10/24 brd 10.10.10.255 scope global eth0
ONIE:/ # ipmitool lan print
Set in Progress : Set Complete
Auth Type Support : NONE MD2 MD5 PASSWORD OEM
Auth Type Enable : Callback :
: User :
: Operator :
: Admin : NONE MD2 MD5 PASSWORD
: OEM :
IP Address Source : Static Address
IP Address : 10.10.10.9
Subnet Mask : 255.255.255.0
MAC Address : b8:6a:97:91:28:0e
SNMP Community String : public
IP Header : TTL=0x40 Flags=0x40 Precedence=0x00 TOS=0x10
BMC ARP Control : ARP Responses Enabled, Gratuitous ARP Disabled
Gratituous ARP Intrvl : 2.0 seconds
Default Gateway IP : 192.168.0.1
Default Gateway MAC : 00:00:00:00:00:00
Backup Gateway IP : 0.0.0.0
Backup Gateway MAC : 00:00:00:00:00:00
802.1q VLAN ID : Disabled
802.1q VLAN Priority : 0
RMCP+ Cipher Suites : None
Cipher Suite Priv Max : Not Available
Use the ping tool to communicate between CPU and BMC.( E.g., ONIE ping BMC)
ONIE:/ # ping 10.10.10.9
PING 10.10.10.9 (10.10.10.9): 56 data bytes //Expected to communicate with no problem but failed.
Caution: It's no problem that external device ping ONIE and BMC. But It's failed to ping from ONIE to BMC.
If so, the NC-SI channel between the CPU and the BMC is disabled. As result, ethernet channel between CPU and BMC is uncommunicated. So when CPU uploaded the BMC firmware to BMC side, it will encounter failure to communicate and failed. The following serial number list contained a potential issue about NCSI. S/N list Notice: Potential issue on AS5916-54XKS only.
Resolution:
Two methods to solve the problem.
- Please follow the procedure file called How to enable _NCSI_ host to BMC path_. – Edgecore Networks.pdf and a zip archive "Tool.zip"which contains two computer files called “main.exe” and “console_port.txt”. Please follow the procedure to recover each switch. After recovery, BMC update via HTTP/TFTP will succeed.
- Just use the BMC web interface to upgrade the firmware. How to update the BMC via the web interface?
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