How to classify and modify the CoS(802.1P) value by DiffServ on ECS4100 series ? Follow
Scenario:

Procedures:
1. Add the VID (VLAN ID) to the port interface. In this example, the traffic will tag VLAN 2.
Console#configure
Console(config)#interface ethernet 1/1
Console(config-if)#switchport allowed vlan add 2 tagged
Console(config-if)#exit
Console(config)#interface ethernet 1/47
Console(config-if)#switchport allowed vlan add 2 tagged
2. Create a class map to classify the specified traffic. In this example, it will match to the traffic of CoS 0.
Console(config)#class-map CoS
Console(config-cmap)#match cos 0
Console#show class-map
Class Map match-any CoS
Description:
Match CoS 0
3. Create a policy map and use the class command to configure policies for traffic which match the criteria defined in a class map. In this example, the value of CoS will be modified to "7" if the traffic match to the class map.
Console(config)#policy-map CoS-test
Console(config-pmap)#class CoS
Console(config-pmap-c)#set cos 7
Console#show policy-map
Policy Map CoS-test
Description:
class CoS
set CoS 7
4. Apply the policy map to the ingress or egress side of a particular interface. In this example, the policy map will be applied to ingress of port 1.
Console#configure
Console(config)#interface ethernet 1/1
Console(config-if)#service-policy ?
input Input direction
output Output direction
Console(config-if)#service-policy input CoS-test
Console#show running-config interface ethernet 1/1
interface ethernet 1/1
switchport allowed vlan add 2 tagged
service-policy input CoS-test
!
Result:
When the switch received the packet of CoS "0" from port 1, this CoS will be modified to "7" then be sent out from the port 47.


Comments
0 comments
Please sign in to leave a comment.