How to Install OF-DPA on Open Network Linux in Edgecore Switches?

Follow

Comments

5 comments

  • There is an issue with AS5812-54X. Launching ofagentapp throws an error as shown below

     

    root@localhost:~# launcher ofagentapp -t 192.168.1.240 -c1 -c2 -c3 -c4 -c5 -a1
    Setting up OFDPA running environment
    insmod: ERROR: could not load module /lib/modules/3.16.53-OpenNetworkLinux/ofdpa/linux-kernel-bde.ko: No such file or directory
    insmod: ERROR: could not load module /lib/modules/3.16.53-OpenNetworkLinux/ofdpa/linux-user-bde.ko: No such file or directory
    mknod: invalid major device number ‘’
    mknod: invalid major device number ‘’
    ofagentapp[11339]: Start command = ofagentapp -t 192.168.1.240 -c1 -c2 -c3 -c4 -c5 -a1
    03-28 14:05:59.603783 [ofagent] version 3.0.5.5 -- Built on Wed Jan 10 2018 at 06:23:37 UTC
    Enabling debugging for component 1.
    Enabling debugging for component 2.
    Enabling debugging for component 3.
    Enabling debugging for component 4.
    Enabling debugging for component 5.
    OF Datapath ID: 0x000000000000DA7A
    03-28 14:05:59.604238 [ofstatemanager] Switch DPID set called but unchanged
    Initializing the system.
    insmod: ERROR: could not load module linux-kernel-bde.ko: No such file or directory
    insmod: ERROR: could not load module linux-user-bde.ko: No such file or directory
    open /dev/linux-user-bde: : No such file or directory
    sdkCustomInit: ERROR: PCI SOC device probe failed
    systemMappingInit: Error initializing driver, rc = -1.

    Failure calling ofdpaClientInitialize(). rc = -27
    ofagentapp[11347]: Received terminate signal

    Can you help find a fix for this?

    0
    Comment actions Permalink
  • Ken Ho

    supposed your ONL version is incorrect.   please download ONL and OF-DPA on the follow links.   Thanks. 

     

    0
    Comment actions Permalink
  • Hi Ken,

    That works well. Now I am struggling with ONOS as it is not detecting the device. Any ideas?

    0
    Comment actions Permalink
  • Ken Ho

    Hi Ademola,

     

    suggest you double check setting of of-dpa agent. make sure controller ip is set properly and restart of-dpa service. 

    refer to http://blog.pichuang.com.tw/ofdpa-with-onl-cheat-sheet/

     

    0
    Comment actions Permalink
  • Hi Ken, 

    I have tried but ONOS is not detecting the device. they are exchanging communications but it keeps breaking. Look at the screenshot below.

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.